互聯網一大進步 IPv6與IPv4協議的比較-IT浪潮-北方網
新聞 | 天津 | 民生 | 廣電 | 津抖雲 | 微視 | 讀圖 | 文娛 | 體育 | 圖事 | 理論 | 志願 | 專題 | 工作室 | 不良信息舉報
教育 | 健康 | 財經 | 地產 | 天津通 | 旅游 | 時尚 | 購物 | 汽車 | IT | 親子 | 會計 | 訪談 | 場景秀 | 發布系統

"津雲"客戶端
  您當前的位置 : 北方網  >  IT浪潮  >  北方學院  >  軟件文庫  >  網絡相關
關鍵詞:

互聯網一大進步 IPv6與IPv4協議的比較


http://www.enorth.com.cn  2007-03-13 15:09

2.3 路由協議

  IP網路由協議主要包括域內路由協議和域間路由協議。

2.3.1 域內路由協議

  目前IP網域內路由協議主要采用IS-IS和OSPF兩種。其中OSPF用來交換IPv4路由信息的版本叫IS-IS用來交換IPv6路由信息的版本叫OSPFv3;IS-IS用來交換IPv4路由協議的版本叫IS-IS,用來交換IPv6路由協議的版本叫IS-ISv6。

(1) OSPFv3與OSPFv2的區別

  OSPFv3(RFC 2740)與OSPFv2(RFC 2328)相比在原理上並沒有根本的區別,OSPFv3仍采用鏈路狀態LSA數據庫,並保持鄰接路由器之間的同步。但由於從IPv4到IPv6上地址長度的變化,為了支持IPv6地址格式,OSPFv3對OSPFv2協議進行了許多修改。從路由協議標准化進程看,OSPFv3協議已較為成熟,已有定型的RFC2740協議。OSPFv3 提高了通用性,使網絡可以適應不斷變化的要求。這使復雜的網絡得以簡化,並且它采取了一些增強措施以保證昇級方便地進行,OSPFv3還進行了優化並且安全性也得到了提高。

  OSPFv3的主要目的是『開發一種獨立於任何具體網絡層的路由協議』。為實現這一目的,C)St」FV3的內部路由器信息被重新進行了設計。與過去的版本不同,()SF·Fv3不向位於數據包和鏈路狀態公告(LSA)起始位置的報頭插入基於IP的數據。C)St」Fv3利用獨立於網絡協議的信息來執行過去需要IP報頭數據的關鍵任務,如識別發布路由數據的LSA。

  除了改變報頭數據外,OSPFv3 還對LSA所發揮的作用進行了重新定義。在OSPFv3中,公告網絡拓撲和IPv6數據的任務被分配到新的和已有的LSA中。

  OSPFv3增加了多種可選功能,如多播OSPFv3,以實現通用性。為了達到這一目的,OSPFv3擴展了網絡設備用來公告使能的功能選項數據域。多數OSPFv3路由器間信息中都包含選項域,運行OSPFv3的設備可以支持多達24種可選功能,而以前的版本只能支持8種功能。

  為了簡化復雜的容錯網絡的建設,OSPFv3引入了Instance ID和R-bit選項。作為每個OSPFv3包頭的一個組件,Instance ID不再依賴於過去需要的復雜的認證方案或訪問清單,就可以控制共享物理網絡和OSPF域的路由器之間的通信。除了Instance ID外,OSPFv3還可以通過R-bit使服務器這類最終系統具有有效的冗餘性。

  OSPFv3與過去的協議的不同之處在於它通過提供非本身固有的安全性來簡化消息的結構。通過利用IPv6包的安全子包頭的集成系統,OSPFv3消息可以被認證和加密,而這在以前是需要增加獨立復雜的協議纔能實現的功能。

  OSPFv3提供了更強的功能,並且它具有很大的通用性,從而可以很方便地支持新型網絡協議。新的特性簡化了網絡設備和運行,在使用OSPFv3的情況下,昇級將不再那麼麻煩。

(2)IS-ISv6與IS—ISv4的區別

  另一個被運營商廣泛使用的連接狀態協議是ISISforIPv6。我們知道ISIS是IS標准路由協議(ISO/IEC10589),最初用於支持CLNS網絡的動態協議。由於ISIS的設計非常有利於新功能的擴展,它首先擴展了IPv4路由協議的功能(RFC1195),有人將這種既能為CLNS服務,也能為IP服務的協議叫做Integrated ISIS。

  依照類似的方法,ISIS也可以通過簡單的擴展來處理IPv6的路由信息。支持IPv6的IS-IS協議標准草案已經經過多次討論修改,目前,還未正式形成RFC標准,只有draft-ietf-isis-ipv6.txt標准草案。 Draft-ietf-isis-ipv6.txt草案通過在IS-IS數據包(Hello、LSP和SNP)中引入以下可變長度的數據域(TLV),從而使其支持IPV6路由功能,這一設計只需要對IS-IS路由協議進行少量的修改即可使它支持IPv6 odraft-ietf-isis-ipv6.txt只增加了有關IPv6的TLV,在鄰居數據庫、拓撲數據庫的建立和維護上基本保持了ISO10589和RFCl195的模式。因此,CLNS IFV4和IPv6具有相同的拓撲結構。也就是說,draft-ietf-isis-ipv6.txt要求IPv4和IPv6的網絡是完全重合的。我們將這種實現稱為ISIS for IPv6單一拓撲模式。

  很快人們認識到單一拓撲模式對IPv4和IPv6網絡完全重合的要求限制了IPv6網絡的部署。顯然IPv6的規模和覆蓋范圍都將大於老一代IPv4網絡,部分網絡將只具有IPv6屬性,例如,部分網絡只有IPv6地址而沒有IPv4地址。這時ISIS for IPv6單一拓撲模式就可能導致一些IPV4的數據報文錯誤地被轉發到這部分IPv6網絡,造成路由的混亂和麻煩,無法滿足IPv4、IPV6不同擴展范圍的需要。ISIS for IPv6多重拓撲模式(draft-ietf-isis-wg-multi-topology)是針對這一問題的解決方案,它通過使用IPv4 IPv6不同的拓撲去除了兩個網絡必須一致的限制。多重拓撲模式為IPv4和IPV6網絡建立不同的拓撲數據庫,分別進行spf最短路徑優先算法的計算,為IPv4和IPv6提供相互獨立的路由子系統,使IPv6網絡的建設擺脫IPv4的限制,為IPv6網絡的成長打開了發展空間。

2.3.2 域間路由協議

  BGP4(RFC1771)是目前被所有IS,運營商廣泛使用的IPv4外部路由協議,BGP4是一個路徑矢量協議,它的基本功能是在自治系統間自動交換無環路的路由信息,通過交換帶有自治區域號(AS)序列屬性的路由可達信息,來構造自治區域的拓撲圖,從而消除路由環路並實施用戶配置的策略。

BGP特點:

*距離矢量協議;

*傳輸協議:TCP,端口號:17;

*支持CIDR(無類別域間選路);

*路由更新只發送增量路由;

*豐富的路由過濾和路由策略。

  支持IPV4的BGP經歷了4個版本:RFC 1105(BGPl),RFC 1163(BGP2),RFC 1267(BGP3),和目前廣泛使用的RFC1771(BGP4)。支持IPv6的域間路由協議是BGP4+,在BGP4+上支持IPv6的路由器必須符合RFC 2858和RFC2545。利用BGP4+實現ISP網絡之間的互通。

  在IPV4環境中,BGP4是一種廣泛使用的用於自治域之間路由傳播的路徑矢量路由協議。在隨後定義的一系列標准中使得BGP4的功能更加強大,可以用於承載多種協議:MPLS-VPN、Multicast等協議均是通過BGP4進行工作的。在RFC 2545(Use of BGP4 Multiprotocol Extensions for IPv6 Inter-Domain Routing)中描述了如何使用MP_REACH_NLRI來傳達IPv6的可達信息。

首頁  上一頁  [1]  [2]  [3]  [4]  [5]  下一頁  尾頁
編輯:趙國棟
[進入IT論壇]
請您文明上網、理性發言並遵守相關規定,在注冊後發表評論。
 北方網精彩內容推薦
無標題文檔
天津民生資訊
天氣交通 天津福彩 每月影訊 二手市場
空氣質量 天津股票 廣播節目 二手房源
失物招領 股市大擂臺 天視節目 每日房價
熱點專題
北京奧運聖火傳遞和諧之旅 迎奧運 講文明 樹新風
解放思想 乾事創業 科學發展 同在一方熱土 共建美好家園
2008天津夏季達沃斯論壇 《今日股市觀察》視頻
北方網網絡相聲頻道在線收聽 2008高考招生簡章 復習衝刺
天津自然博物館館藏精品展示 2008年天津中考問題解答
帶你了解08春夏服飾流行趨勢 完美塑身 舞動肚皮舞(視頻)
C-NCAP碰撞試驗—雪佛蘭景程 特殊時期善待自己 孕期檢查
熱點新聞排行 財經 體育 娛樂 汽車 IT 時尚 健康 教育

Copyright (C) 2000-2026 Enorth.com.cn, Tianjin ENORTH NETNEWS Co.,LTD.All rights reserved
本網站由天津北方網版權所有